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Whole Slide Image (WSI) Analysis with QuPath &empaia

ACADEMY

Objectives:

learn how to get started with the open-source software QuPath
train QuPath to distinguish tumor / non-tumor

use QuPath for Ki67 Analysis

apply the trained algorithm to other regions of interest
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2.
3.
4
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(A) Set-Up Project in QuPath

(1) Download & Install QuPath
(2) Create Project & Add Whole Slide Images
(3) View & Explore WSI



(1) Download, Install and Open QuPath

1. Download & install the QuPath Software suitable for your operating system
from https://qupath.github.io/

2. After successful installation, you can find the QuPath Icon on the desktop:



https://qupath.github.io/

(2) Create Project in QuPath and Add Images

] @ QuPath
1' Create PrOJeCt il Edit Tools View Objects TMA  Measure Automate
“File” > “Project” > “Create project” [ Project.. | (g
( Recent projects.. ¥ | Open project |
Open.. Ctrl+0 | Close project 3
Open URL.. Ctrl+5hift+0 | Add imanec 5

2. Add WSI to Project:
a. “File” > “Project” > “Add images”
b. drag&drop Ki67 image to pop-up window, and set image type “Brightfield (other)’

@ QuPath
ICl Edit  Tools View Objects TMA  Measure  Aut Sk AT EEs .
- i Brightfield (H-DAE)
Project... ] - L Rotate image
poect. [ : T h—
Recent projects... ¥ Open proiect Cprenalarss Brightfield (otheg)
pEn Pl v/| Auto-generd oL el ‘k‘
Open... Ctrl+0 | Close project : Import objeq | MOTescence
i = — Other
Mot set

F_KFICII't Image list Impart Abbrechen



(3) View & Explore WSI in QuPath

1. Open WSI

(double-click on image name in the image list)

2. Explore the image:
scroll to zoom in and out...

T~

press left mouse key to drag the image...

@ QuPath
File Edit Tools View Objects TMA  Measure Automate Analy
B (¢lallellszlve]a]l2] s] (@
Project | Image | Annotations | Hierarchy | Workflow

Create project Open project Add images
Image list

¥ myQuPath-ECDP-WS/project.qpproj (2)

I DigitalSlide_1.svs

DigitalSlide_2 svs




(B) Train Classifier for Tumor/Non-Tumor

(1) Make ROI with Region*

(2) Annotate Tumor Areas within that region

(3) Annotate Non-Tumor Areas within that region
(4) SELECT that annotation

(5) Train Classifier



(1) Annotate Region of Interest

1. Step 1: Select Annotation-Class “Region™*”:
> 1. click on "Annotations”

*7

> 2. click on “Region @ upath 2
> 3. click on “Auto set” Fil-.=..- .I.Edit”T-ooIs View Objects
_ | [«][@)o]l/]xz
2. Step 2: Select Annotation Tool: (e.g. Rectangle)

Project | Image || An ierarchy

@ QuPath - 3svs
File Edit Tools View Objects TMA Messure Automate Analyze Classify Extensions Help

B B olloz=lviz]x]iz]] [s]] [@]] s DG E R 2| =

Project | Image | Annotations | Hierarchy | Workflow
[J Annotation (Rectangle) (Region®) | None
W Tumor
Stroma
M Immune cells
W Necrosis
Other
W Region® (1)
Ignore*

3. Step 3: Draw Annotation

W Negative

to mark Region of Interest




(2) Annotate Tumor Areas

1.

Step 1: Select Annotation-Class “Tumor”:
> 1. click on "Annotations”
> 2. click on “Tumor”

> 3. click on “Auto set”

Step 2: Select Annotation Tool: (e.g. Polygon or Bru
|
File Edit Tools WView

R ) allo]l -

Draiart | lrmama | Annadztinne || Hiararcbas | W rleflana

Step 3: Draw Annotations e -.' e sk
to Mark Tumor Areas WL

@ QuPath - DigitalSlide_1.svs

File  Edit

Project | Image | Annotations

—

Select all

Tools

Delete

View

Objects  TMA  Measure  Automate

R M allollllclv|elx][s]l s

lierarchy | Workflow

Mone

!rom a .

M Immune cells

M Mecrosis
Other

M Fegion®
lgnore*

M Fositive

M Megative

Set class




(3a) Create Annotation Class “Non-Tumor”

1. Select
“Annotations” > “Add/Remove...”Add class”

\>

2. Name the new class

T I s T Y

ﬂ QuPath - 3.5vs

File Edit Tools View Objects TMA Measure Automate Analyze Classify  Extensic
| (OO 2|E (| V||L]AN]||] S]] |D] 784 @ |
Project | Image | Annctations || Hierarchy | Workflow |

‘t) Annotation (Polygon) (Tumor) M

Q] Annotation (Polygon) (Tumer) W Tumor (7) e '
-_"i) Annctation (Palygon) (Tumar) Stroma Populate from existing objects  »
M Immune cell; .
PAnnotation (Polygan) (Tumar) _ Populate from image channels
W Necrosis
<> Annotation (Polygon) (Tumor) Other Reset to default classes
) Annotation (Polygon) (Tumor) W Region* Import classes from project
§ Annotation (Polygon) (Tumor) Ignore* ShowyHide... b
W Fositive Select objects by classification
W Negative |

e 570 -

ﬂ Add class

o Class name ’Hon-Tumori

OK

Abbrechen



(3b) Annotate Non-Tumor Areas

1. Step 1: Select Annotation-Class “Non-Tumor’

> 1. click on "Annotations”
> 2. click on “Non-Tumor”
> 3. click on “Auto set”

2. Step 2: Select Annotation Tool:

(e.g. Polygon or Brush)

3. Step 3: Draw Annotations
to Mark non-tumor Areas

ﬂ CuPath - 3.5vs

File  Edit

R ool |[c]v] e

Tools View Objects TMA N

Project | Image | Annctations | Hierarchy | Workflo

ht) Annotat
ih Annotati
5:') Anncta
P Annotatic
<> Annota
5 Annota

9 Annotatic

Mone

W Tumaor (7)
Stroma

B Immune cells

W Necrosis
Other

M Region®
lgnore*

M Fositive

M Megative



(3d) Train Classifier e B e vee

P || 1 Object classification » || &2 || B = | C

1 Pixel classification  » [ pixel classifier i

Select the Region of Interest

Training images ll Train pixel classifier Ctrl+Shift+P

2. Step 2: Select “Train Pixel Classifier”

ER N 3 Rl TR SRR . U e B

B Pixel classifier

/ Classifier | Artificial neural network (ANMN_MLF) + || Edit
1. Step 3: Configure Pixel Classifier Resalution | Moderate (400 um/px) al )

a. set Resolution to “Moderate”

b. set Region to “Everywhere” Features Default multiscale features - Edit Show -
C. click on “Live prediction” Output | Classification v || Show | ™ s
(and wait for result) , B L o
d. use the slider to adjust the transparency Region | Everywhere Ly
of the result visualisation so that you Load training Advanced optians 5
can check the plausibility of the result f EP—
ive prediction C
— if the result is not good yet, try another [s
resolution (e.g. “Extremely low” ...) ‘
¥ Stroma
' . Tumor

2. Step 4: Name and Save your Classifier

Classification: Strema

Classifier name Show classificgiy
: O m



@ QuPath - DigitalSlide_2.svs

File Edit Tools View Objects TMA Mea
|%| |‘*‘| O O / = V d?

(4) Automatic Tumor Annotations P

Annotation (Polygon) (Stroma) None

Annotation (Polygon) (Stroma) B Tumor (6)
Stroma (4)

1. Step 1: Select Region of Interest from Annotations’ list Annotation (Geomeon) (Stromal o mmune cells

=y Annotation (Polygon) (Tumor) B Necrosis

. .pn . “ . ” Ql,;-'mnotation (Polygon) (Tumar) er
2. Step 2: In Pixel classifier window select “Create objects ’ -

Q Annotation (Polygon) (Tumor) | | 1l Region* (1)
¥ Annotation (Geometry) (Tumo lgnore*

3- In pop_up WindOWS Choose parent ObJeCt Annotation (Geometry) (Stromy | Il Positive

« . » ¢} Annotation (Polygon) (Tumor) | B Negative
Current selection
. « N ocose parent objects )
and object type “Annotation” o prentcbes Qe

@ Pixel classifier x

. . . ‘L| Abbrechen assifier ificial neural ne¥yor - i
4. — find automatic annotation of el —e] T AR =

— e - Resolution | Very low (7.76 um/px

d eteCted tu m O r areas I n th e ﬁ Create Dbje{t; - % Features Default multiscale featu

v || Edit || Show

An notations! I iSt / o New object type Annotation - Output Classification * | | Show
Minimum object size | 0 TP Region Any annotations =
@ QuPath - DigitalSlide_2.svs - ) A2
Minimum hole size 0 Load training Advanced options

File Edit Tools View Objects TMA PFasure  Automate  Analyze  Classify  Extensic

Split objects [
I S I + = [N IVAIN=SIR"AIRY IR S D | 0.39x ® | Delete existing objects

Create objects for ignored classes

Live predifion

Project | Image | Annotations | Hierarchy | Wogfflow |~ Set new objects to selected

Annotation (Polygon) (Stroma) one

w2 : ] Classification: Stro
Annotation (Polygon) (Stroma) Tumar (5) 5 1 ﬁl Abbrechen —
!

Classifier name | tumor-clossifier= Save 5
=5 Annotation (Polygon) (Tumor) Stroma (3) + o g o I
Immune ce . ) . -
< Annotation {Palygon) (Tumor) L ; . Measure C"EatEhJECtS Classify i
. W Necrosis I 5 ek b ———— = |
Q Annotation (Polygon) (Tumor) ‘ Other e ‘ - ‘_

i

M Region* (1]
Annotation (Geometry) (Stroma) Ignore*

Annotation (Geometry) (Tumar)

O Annotation (Polygon) (Tumor) M Positive



(C) Ki67 Analysis

(1)Select/Define Area for Analysis
(2)Detect Positive Cells



ad (C) Ki67 Analysis: Background Information

Ki-67 is a commonly used indicator of cellular proliferation in cancer

Ki-67 Positivity along the Cellcycle:

Source: : Anti-Ostrogentherapie:
Einteilung nach Goldhirsch et al. (2005)

G1 S GZ P[O Pro Meta Ana Telo endokrin nicht ansprechbar (ER-/PR-
meta negativ) Allred Score (Harveyet al.)

. .
L -

Interphase Mitose-Phase
(prepare cell for DNA replication)

— cell division

[number of positively stained tumor cells]

Ki67_index [%] =

[total number of tumor cells]




(1) Select/Define Area for Analysis

1. in the Annotations’ list select the annotation of a tumor area
(e.g. the annotation of the automatically detected tumor areas)

@ QuPath - DigitalSlide_2.svs

File Edit Tools WView Objeds TMA Measure ;-".ut-;:nmatel
1R [(#]Oo/Oo|/|E|V|&N| &[S

Project | Image | Annotations | Hieraggh orkflow ‘
Annotation (Geometry) (Tumor) Mone |

W Tumor (5)
Stroma (3)

M Immune cells

Q, Annotation (Polygon) (Tumor)

[1 Annotation (Rectangle) (Region™)

Annotation (Polygon) (Stroma) ]
Q} M Necrosis
Annotation (Polygon) (Tumaor)
Fheniregen Lamen Other

~ R R ; | |




(2) Kie7 Analysis: Detection of Positive Cells

2. from the QuPath menu select “Analyze”>"Cell detection”>"Positive cell detection”

3. in the “Positive cell detection” pop-up window click on “Run”

4. Wait for the result...

rtomate Classify Extensions Help

5

Preprocessing = & | 88 | 5| & ?

Tiles & superpixels » =

T

ENEI B pocitive cell detection

Spatial analysis U
Deprecated ¥ | Fast cell counts (brightfield)
Density maps U o | 5

B Positive cell detection

Setup parameters

Detection image
Requested pixel size
Nucleus parameters
Background radius
Median filter radius
Sigma

Minimum area
Maximum area
Intensity parameters
Threshold

Max background intensity

v/| Split by shape

Hematoxylin OD

0.5

400

0.1

2

Exclude DAB (membrane staining)

Cell parameters.

Cell expansion

¥ | Include cell nucleus
General parameters

| Smooth boundaries

v| Make measurements

Intensity threshold parameters

Score compartment
Threshold 1+
Threshold 2+
Threshold 3+
/| Single threshold

|

»~

5pm 9

]

Nucleus: DAB OD mean ~ T
02 E

04 F

06 ]

m] X
- |k
um
urn E
iy k
pm ]

=
3
o
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(3) Ki67 Analysis Result

@ QuPath - DigitalSlide_2.svs
File Edit Tools View Objects TMA Measure Automate Analyze Classify

B B (ool e]v][@]a]l&] (s] (@] wan
‘VProject Imager ernnctations :‘ Hierarchy | Work (~

¥} Annotation (Geometry) (Tumor) (| None

‘-:'
B

4. Find the result

Q Annotation (Polygon) (Tumor) (14! B Tumor! | | & ?
= 2 S . £
[] Annotation (Rectangle) (Region®) Strome Lo - vy
I
Annotation (Polygon) (Stroma) i v -

>
Q Annotation (Polygon) (Tumor) %

< >

Selectall | Detete ||| .|.]:

Key Value

Image DigitalSlide_2.svs

Name Tumor

Class Tumor

Parent Image

ROI Geometry

Centroid X um 76343482

Centroid Y ym 5113.0687

Num Detections 62508

Num Negative

Num Positive 10522

Positive %

Num Positive per mm 1267.3066
Area pym*2 8302647.3819
Perimeter um 562593.7585




(D) Apply Trained Algorithm to Other Region

(1) Define another Region of Interest
(2) Load Pixel Classifier
(3) Cell Detection



(1) Define Region of Interest

1. In the Project’s Image list double-click on the @ Cuparn -t

. . File Edit Tools -_‘v'f-ex-.' Objects TMA  Meas
file name to open the respective WSI — W oA

Project | Image | Annotations | Hierarchy | Work (=

2. Draw Region of Interest (e.g. rectangle annotation) Creste project | Openproject | Addimages

Image list
* myQuPath-ECDP-WS/project. gpproj (2)

@ QuPath - DigitalSlide_1.svs Digital Slide_1.svs

File Edit Tools View Objects TMA Measure Automate Analyze Classify Extensions Help

| B (allellzll]vel[N][&] [s]] [@]] o2ax ® | [B)[33)[55)[ 2 |[C

DigitalSlide_2 svs

Project | Image | Annotations | Hierarchy | Workflow

Annotation (Rectangle) (Rggion") None

W Tumor
Stroma

M Immune cells

W Necrosis
Other

M Region* (1)
Ignore*

M Positive

M Negative




: - Eersions _Help
(2) Load Pixel Classifier —

Pixel dlassification  »

»

1. From the menu bar select

Load pixel classifier ‘|

Train pixel classifier CtFSnNC:P

Training images
/ Create thresholder

50 = |[C

“Classify”>"Pixel classification”>"Load pixel classifier’
2. Inthe “Load pixel classifier” pop-up window choose
the (previously trained) tumor classifier /

— result: classifier is applied and tumor areas are detected

=4 Region

B Load pixel classifier

Choose model

tumer-classifier-1

2}

-

3. Create the annotation object for the detected tumor areas
Step 3a: in the Annotations’ list select the Region of Interest
Step 3b: in the “Load pixel classifier” window click on “Create objects”
Step 3c: in the pop-up window choose “Current selection” as parent object

Step 3d: select “Annotation” as new object type
— result: find annotation for the detected

. . T MNew object type Annotation -
tumor areas in the Annotations’ list (2) L D;:{Umﬁ
Minimum hole size 0 H

Project | Image | Annotations || Hierarchy Split objects
Delete existing objects
] Ago

Annotation (Geometry) (Tumeor)

@ Create objects [m] *

agign”) (2 ol Create objects for ignored classes

Set new objects to selected

Annotation (Geometry) (Stroma) oK Abbrechen

Choose model | tumor-dassifier-1

Region Any annotations

Measure Create objects

Q@ Pixel classifier




(3) Cell Detection

1. In the Annotations’ list select the previously generated
annotation of the detected tumor areas

2. Inthe menu bar go to
“Analyse” > "Cell detection” > "Positive cell detection”

@ QuPath - DigitalSlide_1.5vs
File Edit Tools WView Objects TMA Measure Automate Classify  Extensions  Help

B (#lollell )] v][2][A][&] [s] rrroesing @& | [ ) [E] 2 ][C

. ) ) Tiles & superpixels »
Praject | Image | Annotations | Hierarchy | Workflow
CeII detection » i
[ Annotation (Rectangle) (Region®) (2 objects) Cell detection

. Calculate features  # e .
Annotation {Geometry) (Tumor) _1 Positive cell detection
Spatial analysis 3

Subcellular detection (experimental)

Annotation (Geometry) (Stroma)

Deprecated * | Fast cell counts (brightfield)

Density maps b

3. In the “Positive cell detection” window click on “Run”
...and wait for result...

Setup parameters

Detection image Hematoxylin OD

Requested pixel size 0.5 i

Nucleus parameters

Background radius 8 Hm
Median filter radius 0 (o
Sigma 15 urmn
Minimum area 10 um*2
Maximum area 400 um#2

Intensity parameters

Threshold 0.1

M

Q Progress

Running...

735 nuclei detected (61%)

Cancel

v

Make measurements

Intensity threshold parameters

Score compartment Mucleus: DAB OD mean

Threshold 1+ : 0.2

Threshold 2+ : 0.4

Threshold 3+ : 0.6

| Single threshold




(4) Cell Detection Result = Ki67 Analysis Result

Q QuPath - DigitalSlide_1.svs

File Edit Tools View Objects TMA Measure Automate Analyze Classify Extensions Help

vy

‘ Project :‘ Image J‘ Annotations J! Hierarchy H Workflow l @ a,} -
______________________ ! L \ & : ; k
[ Annotation (Rectangle) (Region®) (2/15( | None 5 ' @ g _
3 N

Wy, Annotation (Geometry) (Tumor) (1542 | B Tumor (1)
[%] Annotation (Geometry) (Stroma) ‘7 A. Stroma (1) v

v

<

, , © | el
| Selectall | Delete | :||se. | A |:]

Key Value
Image DigitalSlide_1.svs
Name Tumor
Class Tumor
Parent Region*
ROI Geometry
Centroid X ym 5344918
Centroid Y pym 3358.7816
Num D i 15405

Num Negative

Num Positive 476
Positive %
Num Pos 23.9252

Area pm”*2 2125710.1031
Perimeter um 293018.8764




Further Reading:

https://qupath.readthedocs.io/en/stable/docs/tutorials/cell detection.html#
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https://qupath.readthedocs.io/en/stable/docs/tutorials/cell_detection.html

